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New Calm & Admin Functionality 

An audit trail for archival location changes (and new location fields) 

Whenever a location on an archive catalogue record is changed now, a record will be made 

of this change in the Movement database. This means that it will now be easy to audit the 

movement history of every archive item (if, for example, an item goes missing during a large 

move). Additionally, archive records now have two location fields, NormalLocation (for the 

location an object belongs in) and CurrentLocation (for the location an object is right now). 

Because of this change, locations must now be changed using the side button strip—

previously, it was possible to type into the archive Location field. However, if a location is typed 

in, rather than added using the side button strip, Calm will have no way to recognise that it has 

changed, and therefore will not create a movement record. Therefore, NormalLocation and 

CurrentLocation are read-only fields. The Location field still exists if you would prefer to have 

free-text location notation, although it no longer links to the Location database. 

To move an item or a hitlist of items: 

• Have the item or hitlist open in the catalogue 

• Click Location on the side button strip 

• Click Normal Location or Current Location 

• Use the search dialogue box to find the location to move the item(s) to 

• Fill in the Movement Details dialogue box that appears once you choose a location 

(this information will go onto the movement record) 

 

• If you are moving one item, tick ‘this record only’ at the bottom; if you are moving a 

hitlist of items, tick ‘the entire hit list’ at the bottom 

• Click OK 

The item has now been moved successfully 

To view the location history of an item: 

• On the Archive Menu, open the Movement Menu 

• Click Search 
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• Enter the RefNo of the item you would like to see a movement history for (you may have 

to add RefNo to the search dialogue box via the Administration Menu first) 

No changes have been made to museum locations, which already worked this way. 

Converting your old locations 

Because Calm now links to locations using the NormalLocation and CurrentLocation fields, any 

data you have in the Location field in the catalogue will no longer link correctly. To fix this, Calm 

includes an update routine that will move the contents of the Location field to a field of your 

choice (probably the NormalLocation field, CurrentLocation field, or both).  

Once you have upgraded to v11, you can run the update routine. Before doing so, make a 

backup of your data in case there are any problems with the update. 

Be careful! This update routine will overwrite data in the field that you copy into. Unless you use 

both Location and NormalLocation or CurrentLocation on a single record, this will not be a 

problem (previously it was not possible to do this on an archive record and very unlikely it would 

be done on a museum record). To see all records with data in both Location and a new 

location field, enter the following into a command line search (accessible within the catalogue 

by pressing F6): (Location=*)&((NormalLocation=*)|(CurrentLocation=*)) 

To access the update routine: 

• On Calm’s main menu, click Administration Menu 

• Click Update Routines 

• Click Mandatory 

• Click Move Location to NormalLocation and the Enter Details dialogue box will appear 

• Fill this out as follows: 

Choose the field you want to use for locations here. 

Probably this will be NormalLocation (for where an 

item belongs), although it could be CurrentLocation 

(for where an item currently is). If you would like to 

use both, you will need to run this routine twice (and 

don’t tick ‘Erase Source?’ the first time) 

 

If ticked, this will erase the original Location field. 

Erasing the field will result in tidier data 

Tick this box. This will ensure the routine applies to all 

records in your database 

Do not tick this box 

• Click OK 

• Click OK in each of the two dialogue boxes which appear, telling you which field 

Location will be copied into and how many records will be affected 
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Support for barcode scanning to make location changes 

If you wish to use barcodes to keep track of item locations—scanning an item’s barcode and 

then a location’s barcode to indicate that the item is moving to that location—the barcode-

scanning app Axiell Move is now available for Calm. Some changes have been made to Calm 

to ensure that it supports this: 

• BarCode fields have been added to the Catalogue and Locations database. If you do 

not use barcodes, these can be ignored. If you do use barcodes, they should hold the 

unique ID number of the barcode for that particular item or location 

• A Package record type has been added to the location database. Currently, this does 

not work any differently to Location record types, although Axiell are exploring 

additional functionality 

• Other changes, invisible to the user, have been made to the API to support Axiell Move 

A new, stricter type of mandatory field 

There is now a stricter type of mandatory field, the ‘required’ field. Required fields, as the name 

suggests, are required. You cannot leave a record without filling in all required fields on that 

record. This is different from the pre-existing mandatory field property, which would warn you 

that the field was empty but let you leave the record anyway.  

 

To set a field as required: 

• Open the Admin program 

• Click File 

• Click Open to open the database the field is in 

• Click Field 

• Click Properties… 

• Find the field in the list of fields at left and click on it 

• Tick the box beside Mandatory (Required) 

No fields are set as Required in the default version of Calm. The existing type of mandatory field 

is still available, but now referred to as ‘Mandatory (Suggested)’. 

A clearer way to add records to an existing hierarchy 

When right-clicking a record in a tree, you can now select the Insert Record option. This will 

create a new record, give it the same identifying number as the record you right-clicked, and 

then increment the numbers of the record you right-clicked and those with a higher number 

than it by one. This can be used if you are trying to catalogue items in order (an 1885 ledger, 

an 1886-87 ledger, an 1889 ledger) and then realise you have missed an item that would 

belong in the middle of that sequence (a Jan-Jun 1886 ledger). If you right-click the 1886-87 

ledger, this would increment the RefNos of the 1886-87 and 1889 ledgers by one and also 

create a record at the correct RefNo for the Jan-Jun 1886 ledger. 
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Insert Record is like the previous ‘Increment Siblings’ function, but its name has been changed 

to be clearer and also it now creates a new record with the chosen identifying number instead 

of leaving an empty space for you to fill. 

Also, the ‘Add Above’ option on the tree menu has been renamed ‘Add Empty Line Above’ 

to avoid confusion with the  button. 

Copy multiple occurrences of fields with the FieldCopy script 

If you need to move the contents of one field into another in a database (for example, if you 

had stopped using one field and wanted to use another instead), this has been possible using 

the FieldCopy script. However, FieldCopy would only copy the first occurrence of a field. If you 

were trying to copy a field like Subject which may have multiple occurrences, each for a 

different subject, every occurrence apart from the first would be left in the old field. Now, an 

‘All Fields?’ tick box has been added to the dialogue box and, if ticked, will move each 

occurrence of the first field into a new occurrence of the second. 

 

Updated ArchivesHub XML reports 

Calm now includes three EAD XML reports for ArchivesHub. One, ‘Archives Hub (EAD v1.0)’, is 

an older template that has been left in for legacy reasons. The other two, ‘Archives Hub (EAD 

2002)’ and ‘Archives Hub Collection Level Only (EAD 2002)’, contain current ArchivesHub 
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export mappings as of 22 March 2017. As always before preparing data for delivery, it is a good 

idea to check with ArchivesHub for the current recommendations and templates 

(https://archiveshub.jisc.ac.uk/calm/), as these may have changed since the release of Calm 

v11.  

These templates can be used both to export data (open the top-level record of the collection 

you wish to export, then click File > Report… and choose the appropriate report) and import it 

(start in the Catalogue database, click File > Import… and choose Report as a method). 

• Archives Hub (EAD 2002) is intended to be used to export an entire collection at a time. 

This is like how previous XML reports have worked in Calm 

• Archives Hub Collection Level Only (EAD 2002) exports just the top-level record in 

collections. It is suitable for use if you do not wish to export detailed series-, item-, and 

other-level records in a hierarchy 

Enlarged dialogue boxes for easier reading 

Some dialogue boxes, such as the one used to choose which fields appear on the Overview, 

have been enlarged to allow you to view the full text of very long field names and also to view 

more fields at a time. 

 

A faster way to re-order fields 

You can now click and drag a field in the Field Order/Group dialogue box (accessible within 

Admin from the Field menu) to change its order on a record. For example, this could be used 

to move the NormalLocation field to the top of all records in the catalogue for easier reference. 

Previously, you would have to click the field and then repeatedly click ‘Move Up’ or ‘Move 

Down’. Additionally, the dialogue box has been enlarged so you can see more fields at once. 

https://archiveshub.jisc.ac.uk/calm/
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→ 

 

It is also easier to find fields in the list: if you click any field in the list, you can then begin typing 

the name of the field you are looking for and will be taken to it. 

The ability to make groups of fields has returned, as well. Groups are shown in the dialogue box 

as a number with a + or – to its left (like ‘200’, in the image above). To make a new group, click 

the Make Group button and a new group will appear at the bottom of the list of fields. You can 

then click and drag it, as you would a field, to where you would like the group to appear in the 

list. Fields can be clicked and dragged into this group, as well. 

You can now make your own Multimedia fields 

It is now possible to create Multimedia fields (which link to images, videos, audio files, and 

documents) in the Admin program in the same way that you can create Date, Line of text, 

Period, Number, and other types of fields. All databases already have a Multimedia field 

(named ‘Multimedia’) by default, so this option is best used if you would like to separate the 

files you are linking to records in some way (for example, to have a new field that holds images 

which you do not wish to be visible on CalmView while you keep the images that should be 

visible attached to the standard Multimedia field). 

To create a Multimedia field: 

• Open the Admin program 

• Click File 

• Click Open to open the database you want to create the field in 

• Click Field 

• Click Define Types 

• Click Add 

Multimedia will now be an option on the ‘Add Field’ dialogue box. Note that this replaces the 

option to create a Tree-type field which was never fully implemented. 

A faster way to apply properties to multiple fields at once 

Previously, the way to apply a property like making a field not indexed has been a slow process. 

You would have to open the Edit Field Properties… dialogue box (available within the Admin 
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program under the Field menu), select a field, and untick the index box, then repeat for every 

field you wished to change.  

Now, at the bottom of the Field menu is an option called ‘Property Editors’. If you hover over 

Property Editors, you will be able to choose the property you wish to apply and view a list of all 

fields that do have the property on one side and don’t have the property on the other. 

Applying the property is as simple as selecting the field and clicking the ‘Add’ button. This 

makes applying a property to multiple fields at once significantly faster. 

 

→ 

 

Two new diagnostic reports in Admin 

The ‘Index integrity check’ and ‘Detailed index integrity check’ reports are designed to help 

diagnose issues around index corruption. You shouldn’t need to worry about these—mainly, 

they are meant to give the service desk more information about issues you may be having. 

They are available in the Admin program, once you’ve opened a database, in the File menu 

under ‘Report’.  

 

→ 
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Other Calm & Admin Improvements 
Calm v11 contains numerous fixes for bugs and other issues. Most notably, the Overview and 

XML reports (like the ArchivesHub EAD export) have received a large amount of development 

attention to stabilise them. A partial list of fixes made in v11 is below. 

Issue Fix 

The HitListFill script accepted more text than it could add 

to a field, so when adding lots of text some may have 

been cut off 

HitListFill will now accept only as 

much text as it can fill in 

It was not possible to insert fields with very long field names 

using Field>Insert  

Calm now correctly handles very 

long field names 

Images linked using the Multimedia field were not 

appearing in the Images Overview 

Multimedia images now appear 

in the Images Overview 

In the Tree Menu, the default for ‘Find record when 

clicking in tree’, ‘Select item in tree when loading record’, 

and ‘Sync tree with current record’ were not selected by 

default and had to be manually selected 

These options will now be 

selected by default in new 

installations of Calm 

If you tried to run an EAD XML report from any level other 

than the top level, you would get an error message saying 

that CountryCode was missing 

It is now possible to run an EAD 

report from any level in the 

hierarchy 

On Windows 10, a title bar menu was appearing in the 

Admin program with buttons that didn’t work 

The menu has been removed 

XML reports were having trouble exporting content if it 

was omitted 

It is now possible to output 

optional fields properly 

HTML reports would sometimes open in Internet Explorer 

instead of the default browser 

HTML reports now open in default 

browser 

‘Help’ buttons in the Admin program were not opening 

the correct help file 

‘Help’ buttons now open the 

correct file 

‘X’ in corner wasn’t closing the Lookup Table dialogue box 

in the Admin program 

‘X’ now closes Lookup Table 

dialogue box 

F1 wasn’t opening the help file F1 now opens the help file 

It was possible to enter letters into the Clone dialogue box 

and click OK, which would cause Calm to crash 

If letters are entered and OK is 

clicked, no records will be 

created and Calm will not crash 

Clicking ‘X’ on the Opening Times parameter dialogue 

box would open a new dialogue box instead of closing 

the existing one 

Clicking ‘X’ now closes the 

dialogue box 
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Some important fields (like Code in the Persons database 

or EntryNumber in the Accession database) were not 

being treated as system fields by Calm 

System field attributes have been 

applied to these fields 

In the Admin program, in Security, users could not be set 

as ‘Disabled’—upon leaving Security, the user would 

revert to ‘Active’ 

Users will now remain as 

‘Disabled’ 

If a hit list was sorted and then a search was run using 

‘Exclude’, different results would be found than if the hit 

list had not been sorted 

Sorted and unsorted hit lists now 

return the same results when using 

‘Exclude’ 

When fields were saved on the ‘Print labels’ dialogue box, 

Calm would occasionally crash 

Calm no longer crashes 

File>Print>Overview could be clicked but would not work 

if the Overview was closed 

It can no longer be clicked if the 

Overview is closed 

Files linked to Calm records would fail to open in an 

external program on every other click 

Linked files now open on every 

click 

Importing an invalid XML file would cause Calm to crash Invalid XML files are not imported 

Clicking ‘X’ on the archive ‘Confirm Loan’ dialogue box 

would issue the loan. 

It is no longer possible to click the 

‘X’ 

Issuing a hitlist of archive loans would not work—you would 

never be prompted for an ‘end day’ 

This now goes through the whole 

process 

XML reports were not running successfully, giving the error 

message ‘Unable to open Persons for exclusive access’ 

XML reports now access 

permissions correctly and can run 

If Edit>Find was run a second time for the same word in a 

very long field, it would highlight the word but take the 

user to the bottom of the record 

Edit>Find now takes the user to 

the highlighted word 

Increment Siblings wasn’t working on trees with lots of 

records 

Insert Record now works on large 

trees 

When a record was imported from DScribe Natural, fields 

generated when a record saved (like PlaceEntry in the 

Places database) were not generated 

When records are imported, 

these fields are now generated 

The log file on installing Calm was the incorrectly 

numbered CALM-9.log 

The log file is now CALM-11.0.log 

When ‘Find record when clicking in tree’ was selected, 

clicking a record in the tree would only select that record 

in the Overview on every other click 

Now when the record is clicked in 

the tree it will be selected in the 

Overview 
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After adding columns to the Overview, changing its size 

would result in only 3 columns being visible 

The Overview will now show all 

columns 

It was not possible to hold down SHIFT or CTRL and click to 

select more than one record in the Overview 

SHIFT- and CTRL-click now work 

with the Overview 

Making field groups was not possible Making field groups is possible 

Some DScribe XML imports were truncating field contents Filed contents are no longer 

truncated 
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New CalmView Functionality 
Because of changes made to Calm’s API to work with Axiell Move and Axiell Collections, 

organisations running Calm v11 must use CalmView v4 and organisations running CalmView 4 

must use Calm v11. 

Many improvements to document ordering and user registration 

Many upgrades and changes have been made to the document ordering process, outlined 

below. 

A user can now cancel in the middle of the registration process  

There is now a cancel button at the bottom of the user registration page. If a user clicks that 

button, the registration process will be aborted and no partial user record will be created which 

must be cleaned up. To support this, all user registration fields are now on a single page instead 

of the two-page setup (page one for user ID and password, page two for contact information) 

which existed before. This also solves the problem of incomplete user records being created if 

a user abandoned the registration process after the first screen: now nothing is created until all 

fields have been filled out and the ‘Create User’ button is clicked. 

 

Set up an expiry date for new user records 

In order to comply with the GDPR and other data protection policies, you may wish to 

periodically purge older user records. CalmView now lets you set an expiry date for a user 

created through the user registration process so that you can periodically check for expiring 

user records to see if they should be deleted. The expiry date is filled into the Expiry field in the 

Users database. 

To enable this, navigate to DataSource>Data Groups>CalmView>My Items in the Configurator 

and tick ‘Give New Users Expiry Dates’, then enter the number of days a user record should be 

valid in ‘Days a User Record lasts’, below it. For example, if you wanted user records to expire 

in two years, you would enter 730.  
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Send confirmation emails to users 

Confirmation emails can be sent to users for registering an account or changing a password. 

You can turn these emails on and off, as well as set their subject lines, in DataSource>Data 

Groups in the Configurator. Data Groups now contains many other settings that you can use 

to set these emails up, as well. 

The texts of each email can be altered in the configurator as well. The new user email text is 

accessed in Pages>Register User>newUserEmail. The password change email text is accessed 

in Pages>Register User>changedPasswordEmail. Each can be altered to what you would like 

the email to say. You can enter the user’s name by typing {0}, the user’s ID by typing {1}, and 

the user’s password by typing {2}. 

Auto-generate user IDs 

Previously, users have had to create their own IDs when creating a user account. If you would 

prefer these to be automatically assigned, that is now possible. To do this, navigate to 

DataSource>Data Groups>CalmView>My Items in the Configurator and tick ‘Auto-Generate 

new User IDs’. The ‘User ID’ field will be greyed out (as in the screenshot above) when a user is 

registering for an account. Upon creating an account, the user will be assigned a number in 

line with the serial numbers in the UserID field (in the Users database). 

Use the user’s name, rather than ID 

Instead of the impersonal ID number, it is now possible to use the user’s name in various places 

throughout CalmView. To show the user’s name at the top of every page when that user is 

logged in (as below), navigate to DataSource>Data Groups>My Items in the configurator and 

change the field ‘Page Header Welcome User By’ from ‘ID’ to ‘UserName’.  

 

To display the user’s name in the welcome message displayed when a user is registered for the 

first time, navigate to Pages>All Pages>User registration complete page in the configurator. 

Typing {1} in the ‘Welcome text’ field will insert the user’s name and {0} will insert the user’s ID, 

as below. 

 

Please note the user will still need their ID to log in, so do not remove all references to it from 

CalmView. 
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See more (and different) fields in My Orders 

The ‘My Orders’ section (available to a logged-in user by clicking ‘My Orders’ at the top right 

of the screen) had previously shown the OrderDate at the top of an order and two fields from 

the ordered items. Now, there are several possibilities: 

• The DueDate can be shown at the top instead of the OrderDate. This is changed in 

DataSource>Data Groups>CalmView>My Items>MyItems_Label_DateDisplay in the 

configurator 

• The column on the far left can hold a loan Id number (drawn from the ID field in the 

Archive Loans database) instead of an ID number from the Catalogue database. To 

make it show the loan ID, tick the box in DataSource>Data Groups>CalmView>My 

Items>MyItems_Label_ShowLoanID in the configurator. Note: this will override any field 

you have chosen for this column in DataSource>Data Groups>CalmView>My 

Items>Label field 

• A third column of data about the item can now be shown, for example to add a Date 

field in addition to the Title field. To add a third field (like the Date field, below), go to 

DataSource>Data Groups>CalmView>My Items>Description Field 2 in the configurator 

and choose a field. If nothing is selected here, there will be no third column 

 

Items a user has tried to order can be re-ordered 

In the ‘Past Orders’ section (available to a logged-in user by clicking ‘My Orders’ at the top 

right of the screen), a user can see previous completed and cancelled orders. Beside each 

item in a past order there is now a Reorder column with a tick box. A user may tick any number 

of items there and click ‘Add to Basket’ to put the items in ‘My Items’ so they can be ordered 

again. 

 

Un-orderable items can link the user elsewhere 

Previously, if an item that was not orderable was added to ‘My Items’ by a user, the space 

where a tick box should appear (to select the item for ordering) was empty, as shown below. 
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Now, it is possible to fill this space with a link—for example, to point a user to a site where it is 

possible to order reproductions, or to policies that explain why items are not orderable—as 

shown below. 

 

To enable this, navigate to DataSource>Data Groups>CalmView>My Items>Offsite Ordering 

URL in the configurator and enter the URL of the site you wish users to go to. Any link entered 

will be used for every un-orderable record. If nothing is entered in this field, CalmView will 

display an empty space, as before.  

Pages in a CalmView site can be indexed by search engines 

In a default CalmView setup, search engines link to your copy of CalmView, but not individual 

pages (for individual records) within it. It is now possible for them to find and link to individual 

pages within your CalmView site if you edit the robots.txt file in the CalmView folder. To do this, 

replace ‘# Sitemap: http://www.myserver.com/sitemap.ashx’ with ‘Sitemap: http://[your 

CalmView domain]/sitemap.ashx’ (note the absence of the initial #). For example, ‘Sitemap: 

http://archives.hemdon.gov.uk/sitemap.ashx’. 

This change was added as an update to CalmView 3.0 after its release, but has been 

integrated into CalmView 4.0 by default.  

An easy way to display original images 

If you would like to display an original image at its full size, with no watermarking or changes of 

format applied to it, this is now a setting available for CalmView images. In the Configurator, 

open Images>CalmView Images, choose the type of image you would like the setting to be 

applied to, and then tick ‘Use Original Image File?’ at the bottom of the screen. This will override 

any settings above including watermarking, so use it carefully. 

.NET 4.0 behind the scenes 

CalmView is now built on .NET 4.0 instead of the previous .NET 3.5. This should make no surface 

difference to you or users of your CalmView site, but it does ensure the program is more secure 

and stable overall. 

  

http://www.myserver.com/sitemap.ashx
http://[your/
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Other CalmView Improvements 
Issue Fix 

A level in a tree with no associated Calm record would 

cause an error when linked 

Clicking does not cause an error 

It was not possible to style individual fields in the record 

view 

Each table row now has the 

field’s name as an attribute, 

allowing CSS styling of specific 

fields 

A space was missing in link tag to default.aspx Space has been added 

No Welsh flag available for switching language to Welsh Welsh flag has been added 

Very long words would run off the end of a table when 

viewing a record 

Wrapping of long words has been 

implemented 

If a search returned no results and document ordering was 

enabled, user would get an error 500 

A more user-friendly message 

now appears 

If a page header was entered into overview.xml, the 

Refine Search button would be misaligned 

Refine Search no longer has a 

relative position so it should be 

correctly aligned 

Terms and Conditions text (set in Pages>All Pages) did not 

appear during user registration 

Terms and Conditions text now 

appears 

It was not possible to translate the ‘Refine Search’ button 

into different languages 

Refine Search is now translatable 

Paragraph breaks were not shown on records Paragraph breaks are now shown 

Thumbnails were not generated for bmp images Bmps now have thumbnails 

If a search was run using the Term/Subject buttons, 

returning to Advanced Search and clicking the buttons 

again would produce an application error 

Leaving Advanced Search, 

returning, and clicking Term/ 

Subject is now possible 

Top navigation bar buttons that had been removed were 

still visible in the text-only version of CalmView 

The top navigation bar is now 

built from the sitemap; these 

options can be removed entirely 

The password reminder page was misleadingly called 

‘reset password’ 

Page name and buttons have 

been made clearer 

If the first word in a showcase description was 1 character, 

it could be put on the same line as the title 

Showcase title line is now 

exclusively for the title 

If an overview was reached by a direct link, clicking Next 

couldn’t take you past the second page of results 

Next will now take you through 

every page of the overview 
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If you attempted to remove the last field from the Quick 

Search, it was not possible to close the warning dialogue 

box that appeared 

It is not possible to remove the last 

field from the Quick Search 

If ordering was not enabled, an empty box would appear 

at the lower-right of the record view 

Empty box no longer appears 

If a user hit the maximum number of ordered items and 

ordered more, the order would not work but no error 

message explaining why would appear 

An error message explaining why 

the order cannot be made 

appears 

If an OrderRefNo was set for an item, CalmView would use 

the OrderRefNo but not check to see if it was already on 

loan 

CalmView now checks to see if 

the item is available 

If changes were made in the Configurator on any pages 

in the Pages section, they would not be saved and the 

Configurator would lock up 

The Configurator now allows 

changes in the Pages section 

In some cases, adding a footer to Advanced Search or 

Image Gallery would make it impossible to click the page 

It is now possible to click the page 

if a footer is added 

In some cases, opening a full-screen image would not 

return the MIME type, so the image would not be 

displayed 

The image and its MIME type are 

now returned so it displays 

properly 

Add to Basket button would not appear if ‘Offline’ 

ordering was selected 

Add to Basket button appears if 

Offline or Calm ordering selected 

Error messages would not show helpful information if 

attached images could not be shown 

Correct error messages display 

The safari.browser file was incompatible with CalmView 

when using .NET 4.0 

The file has been removed 

If ‘current search terms’ were clicked in the Advanced 

Search, a server error page would appear 

The server error message does not 

appear 

Clicking the font size buttons would lead to a server error 

page 

The server error message does not 

appear 

On the user Login page, clicking ‘Enter’ did not log the 

user in 

Focus is now on the ‘Log In’ 

button, so hitting Enter logs in 

Searched-for terms were not highlighted in the record 

view 

A change in how Calm passes 

data to CalmView has made this 

possible again 
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